
BB FLASHBACK PRO V4 
Screencasting 
 

  

1 | P a g e  
 

Last updated Tuesday, 11 June 2013 

 

BB Flashback lets you record anything on your screen, not just a PowerPoint 
presentation. If you have a microphone you can record audio, and if you have 
a webcam you can record yourself. It is easy to use, and comes installed as 
standard on your Glyndŵr computer. You can save the video in a variety of 
formats, for example as a Flash video, or you can upload to YouTube. 
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WHY USE A SCREENCAST? 

Some ideas for using a screencast include: 
 

1. Introduction to your course – you could use a screencast to show students how to navigate 
around your Moodle course, where to find specific information, and so on. 

2. ‘Flip’ the classroom – record your lecture as screencasts which are made available on your 
Moodle course and which students are expected to watch before class. You can then use the 
class time for group work and/ or discussion/ questions relating to the ‘lecture’ content. 

3. Giving student feedback – if students have submitted work electronically, you could display this 
on the screen whilst you provide audio feedback. 

4. Demonstrate a new piece of software - a screencast can help demonstrate a practical technique 
prior to lab work or a practical session. 

5. Student presentations – students also have access to BB Flashback on some university 
computers, so you could encourage them to create a screencast to submit as a piece of 
assessment. 

 

 

PREPARE FOR YOUR SCREENCAST 

It is useful to do some preparation work before you begin recording. 
(However, it is easy to edit your screencast later if you have made a mistake, 
missed something out or the phone rang whilst you were recording.) 

1. Prepare what you want to record and say. You can create a script if you want, or a rough plan (if 
you have PowerPoint slides these will guide you, as they do in a lecture). 

2. Make sure that the screencast is not too long (roughly 5-10 minutes). If you want to create a 
longer recording, think about breaking it down into sections. 

3. Don’t expect your screencasts to be perfect – they will be more engaging if they sound natural 
anyway. 

4. Use an external microphone so that you can record your audio clearly without too much 
interference. If you have a relatively new computer, you may not need an external mic to record 
audio, just a quiet place to create your screencast. 
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RECORDING 
 

1. Open BB FlashBack by clicking on Start > All programs > Blueberry Software > BB Flashback Pro 
4 > BB Flashback Pro 4 Recorder  

Or 

Start > Programs > Common Apps > Blueberry Software > BB Flashback Pro 4 > BB Flashback 
Pro 4 Recorder 

  

2. Make sure that you have BB Flashback Pro 4 installed on your computer. If not, please contact IT 
Services who will be able to get this installed for you. 

3. If you are asked to check for updates, click on Cancel. 

4. Click Record your screen. 

 

http://servicedesk.glyndwr.ac.uk/portal
http://servicedesk.glyndwr.ac.uk/portal
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5. Decide which area of the 
screen you want to record 
(Fullscreen, Region or 
Window). 

6. Choose your devices for 
recording sound (e.g. 
microphone, in-built 
speakers) 

7. You can record the 
webcam if you have one 
(tick the Record Webcam 
option). You can choose 
whether or not to Show 
webcam window while 
recording.  

8. Tick the Minimize to tray 
while recording option.  

9. When you are ready to 
start recording, click the 
big red button. 

 

10. You will then see an icon at the bottom of the screen while you are recording: .  

11. Double click on the icon to bring up the floating toolbar: 

 

12. This shows you how long you’ve been recording for. You can pause your recording and stop your 
recording. 

13. When you stop your recording, you can either Save or Discard it. If you are happy with the 
recording, click Save or if you want to start again, click Discard. 
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14. The Save as window opens, and usually you are prompted to save your movie in a folder called 
BB Flashback Movies within the My Documents area of your computer. 

15. Name your file and save it to the folder you want to keep it in. The created file is the BB 
Flashback file (.fbr). If you need to edit your screencast, you can do so from this file. 

16. Once you have saved your file, you have the option to Open in Player or Export. If you wish to 
edit your recording, click on Open in Player. 
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EDITING AND ANNOTATING YOUR RECORDING 

When you want to make changes to your recording, it is useful to know 
where to find the relevant tools and options. Here we explain what the 
different toolbars and areas on the screen can do. 

 

 

 

 

 

 

 

The toolbars at the 
top show commonly 
used features 

The main area is 
where the recording 
plays back 

The frame bar 
lets you select 
frames for editing 

The objects bar 
enables you to edit any 
text box, image, etc.  

The Sound bar makes it easy to select and edit sound in 
the movie (there may be more than one sound bar if 
more than one sound source is used e.g. microphone, 
second microphone recording, PC speakers etc.) 

The timeline lets you 
jump to any point in 
the recording 
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Delete frames 

You may want to remove frames if there are sections of the recording where 
you paused or somebody made a noise, or at the end of a recording where 
the floating toolbar appears when you are stopping the recording. 

1. Use the mouse and the frame bar to select the frames that you want to delete. 

2. Then either click on the Delete frames button  or go to Edit > Delete frames. 

 

3. You are asked what you want to do with the sound – make sure Shift it left is selected so that 
the synchronisation of sound and video later in the recording is not affected. Click on OK. 

 

4. If you have made a mistake you can 
always use the Undo button, or go to 
Edit > Undo: Delete frames. 
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Add a textbox 

1. To add a textbox, either go to Insert > Text or click on the Add Text icon. 

 

2. You can change the font size, colour, 
alignment and shape of the textbox.  

3. If you want to pause the movie until 
the textbox has been clicked, use the 
Pause movie at this textbox until 
mouse clicked option, and you can 
decide whether to pause the movie 
until the mouse is clicked or to pause 
it for a certain length of time. (This 
would only work if you are saving 
the movie in a Flash format). 

4. Use the Appearance tab to change 
the background and border colours 
of the textbox. 

5. There are a number of different 
styles available on the Style tab. 

6. You can also change the size on the 
Position tab. 

7. You can add a Fade In and Fade Out 
using the Transitions tab. 

8. Click on OK. 

9. Once you have decided on the appearance of the textbox, you can reposition and resize it by 
dragging.  

10. You can also make it appear on the screen for longer by dragging across on the Objects bar. 

11. You can also move the textbox to a different place in the movie, or copy and paste it to another 
place in the movie.
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Add a new section 

If, after recording and editing, you realise that you have missed something 
out of your movie, it is easy to add a new section by creating a new 
recording, and inserting this into the relevant area of the original recording. 

1. Record a new BB Flashback movie with BB Flashback Recorder to cover the section that you 
have missed out.  

2. Open the new file in the BB Flashback Player to edit as necessary. 

3. Save the file with a name and location you will find easy to locate. 

4. Open your original movie in the BB Flashback Player. 

5. Find the place in the movie where you want to add the new section (you can use the timeline or 
the frame bar). 

6. Go to Insert > FlashBack Movie. 

 

7. On the Insert Movie window , click on the 
browse button to locate the new movie 
you have created. 

8. Use the Browse window to drill down and 
locate the new movie. 

9. Click on Open.  

10. On the Insert Movie window you can 
make changes to how the new section 
appears. If you do not want any sort of 
‘fade in’, then select No transition next to 
In: on the In tab under Transitions. 

11. You may also want to click on the Out tab 
under Transitions to select No transition 
next to Out:. 

12. Click on OK.  
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Edit Sound 

If you want to edit the sound or record new sound on a particular section, 
this is also easy to do. 

1. To mute the sound on a particular section (to edit out a cough, for example, or change what you 
said) select the frames you want to mute the sound on, using the timeline or the frame bar. 

2. Then use either the Mute Sound Selection button, or go to Sound > Mute Sound Selection. 

 

3. The muted sound will then appear on the selected area as ‘greyed out’. 

 

4. You can then add a sound file that you have already prepared elsewhere, using the 
button, , or go to Sound > Add Sound.  

5. On the Sound Properties window, click on the browse button to open the Browse window and 
drill down to locate your previously saved sound file. 

6. Alternatively, you can record over the muted section. Use the  button, or go to 
Sound > Record Sound. 

7. In order for the sound to appear exactly where you want it to, I would recommend starting the 
recording a few frames before. You will see a new sound bar appear (e.g. Microphone2). You can 
always Undo the recording, or make changes in the usual way. 
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Add Zoom effect 

1. To select an area where you want to zoom in, find the relevant frame using either the timeline or 
the frame bar. 

2. Then either click on the  button or go to Effects > Add Zoom/Pan. 

 

3. On the Insert Zoom/Pan Keyframe window 
select Custom area.  

4. You can also use the Size and Position tab 
to change the appearance. Click on OK. 

5. On the Frames bar, the green frame shows 
the zoomed in area. 

 

6. Still on the Frames bar, select the area 
where you want to zoom out. 

7. On the Insert Zoom/Pan Keyframe window 
select Whole movie.  

8. In order for the zoom to take effect, you 
then have to click on Effects > Apply 
Effects. 

 
 

9. If you try to play the movie without having applies effects, you will see the following message. Click 
on Play with effects to view your zooms.
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Save your recording 

Whenever you have made changes that you are happy with, remember to save your recording. 
To do this, go to File > Save or Save As… 

 

 

EXPORTING YOUR RECORDING 

When you are happy with your recording, you will need to save it in a format 
that means you can easily share it with your students or colleagues.  

1. Go to File > Export… 

 

2. Choose an appropriate format: 

Flash – this is the best format for ease of use, quality and size of file. Also, any pauses or ‘click 
to continue’ features that you have included in the video would work in this format. 
Unfortunately, there are some devices (e.g. IPads, IPhones etc.) which will not play flash files 
correctly. However, you could direct students with IPads to try using the Puffin browser – this 
should allow them to view flash files without a problem. 

QuickTime – the quality of the exported file is very good, but the file size is very big – it could 
take a while for users to open, depending on the device used and the internet connection.  The 
user would also need the relevant software available on their device. 

http://www.puffinbrowser.com/index.php
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Windows Media Video – again, the user would need the software on their device, and it could 
take a while to download as the file produced is large. However, the quality is very good. 

MPEG4 – the advantage of this format is that the file size is small (not much bigger than the 
Flash file size). It would also play on most Apple devices. However, the quality is not very good. 

 

3. When you have chosen a format, click on OK. 

4. You can make changes to the Export options if you wish, but in general we would advise leaving 
them as the default.  

5. Click on Export. 

6. The Save As window will open again. You may want to rename the file produced, but ensure you 
do not change the suffix (e.g. for Flash files, leave the .swf at the end of the name). You could 
also change the location of the exported file. 

7. It could take a few minutes or longer (depending on the length of the recording). 

8. When the export has finished, you will be asked Do you want to view the export now? Click Yes 
to view the exported file in its saved location. 
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Add video file to Moodle 

To add your video file to your Moodle site you should add it as a file. 
(Alternatively, you can embed a QuickTime file within the text editor of a 
label, page or book using the Moodle Media button). 

1. On your Moodle course, Turn editing on. 

2. Use the Add a resource… File option 

3. Give it a Name and a Description and browse to the exported file on your computer by clicking 
on Add, and Upload a file in the usual way. 

4. Under Options, and next to Display, 
choose the appropriate option: 

In pop-up – suitable for flash (.swf) and 
QuickTime (.mov) files 

Force download – more appropriate for 
Windows Media Video (.wmv) or MPEG4 
(.mp4) files 

 

5. Save and return to course. 

6. Depending on the file type you have chosen, the icon may display differently: 

 

7. The video should open in a new window when the user clicks on the link. 

8. An alternative is to embed your video using the Moodle HTML/text editor. This works best on 
QuickTime (.mov) files. (Flash files display a URL, and MPEG4 and Windows Media Video files 
display a video but do not play correctly). 

9. To do this, Add a resource…Label (or Book, or Page). 

10. On the text editor, click on the Moodle Media button.  

11. Click on Find or upload a sound, video or applet… and then drill down to find the video on your 
machine in the usual way by clicking on Upload a file. 

12. Insert, and then Save and return to course. 
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Return video feedback as a response file 

If you have created a screencast of feedback on a student’s assignment, the 
safest way to send this back to the student would be via a Moodle 
assignment as a response file. 

1. On your Moodle course, click on the link to the assignment. 

2. Click on the link on the top right which says View # submitted assignments.  

3. You see a list of students’ names, with details of their submissions. Scroll across (using the 
horizontal scrollbar at the bottom) until you see the Status column, and click on Grade or 
Update to send the student a response file. 

4. Next to Response files, click on the Add… button.  

 

5. Use the Upload a file option, and Choose file to drill down to the exported file you have saved 
on your computer. Upload this file. 

6. You can give a Grade and some Feedback to the student in the usual way. 

7. Save changes or Save and show next.  
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UPLOAD TO YOUTUBE 

One way you can share your recording with students is by uploading it to 
YouTube (please note that the maximum length of video is 10 minutes). The 
video can then be embedded on a Moodle course or you can share the link 
with students via email, Twitter, Facebook etc. It is the most accessible way 
of sharing the recording, as it does not matter which device or platform the 
user is trying to access the video from – as long as they have an internet 
connection it should play.  

However, for some videos, i.e. screencasts giving students feedback, it is not 
appropriate to upload to YouTube and you would be best to export them. 

 

Step 1: Create a YouTube account 

1. If you already have a YouTube account, proceed to step 2. 

2. If you have a Google account, you can log in to YouTube with your Google username and 
password: http://bit.ly/GJS6Ql  

3. If you do not have a YouTube account or a Google account, you need to create a Google account 
to access YouTube. You can do so via the following link: http://bit.ly/GTtMdX  

 

Step 2: Set up YouTube Profile. 

The first time you use the BB Flashback Player you will need to set up a 
YouTube profile. 

1. Open up BB Flashback Player. 

2. Go to File > Manage Upload Profiles.  

3. In the Manage Upload Profiles window 
click on Add… 

4. The New Profile – Upload Type window 
opens. 

5. From the dropdown menu under Select 
the type of server to upload to, choose  
YouTube. 

6. Click on Next >. 

http://bit.ly/GJS6Ql
http://bit.ly/GTtMdX
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7. The FlashBack4 YouTube – Video 
Formats window opens.  

8. Tick the box to the left of Flash Video 
(FLV). 

9. Click on Next >. 

 

 
 

 

10. On the YouTube window, enter your 
YouTube Name and Password. 

11. It is a good idea to keep the Allow user 
to change these settings when 
publishing the file setting ticked, in case 
you ever change your YouTube 
password. 

12. Click on OK. 

 

 

Step 3: Upload your video. 

1. Open your recording in the BB Flashback Pro Player. If you have not saved this to a different 
location it should be under My Documents > BB Flashback Movies. 

2. On the top left, click on the option: Upload 
to YouTube. 

3. Alternatively, go to File > Upload > 
YouTube. 

4. You will be asked to enter your YouTube 
Name and Password.  

5. Click on OK. 
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6. Enter the Movie Details: 

Title: Give your video a title 

Description: You can give your video 
a short description. 

Category: Choose the best category 
for your video e.g. Education. 

Tags: Tag your video with keywords 
(separate words/phrases with a 
comma) 

For the time being, tick to keep the 
video Private. 

7. Click on OK. 

8. Depending on the length of the 
recording and the size of the file, the 
upload could take a few minutes or 
longer.  

You will see a message telling you 
how much of the video has been 
exported to FLV. 

And then a message saying how 
much longer the upload is going to 
take. 

 

 

9. To view your video and make changes, click on Open in Browser: 
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Step 4: Edit settings, including Privacy Settings. 

1. To edit settings, click on Video Manager. 

 

2. You see a list of your uploaded videos. Next to the video you have just uploaded, click on Edit. 
 

3. You can make changes here to the Title, Description, Tags and Category if you wish. 
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4. You should also choose the appropriate Privacy Settings: 

Public - means that anyone on YouTube can view and search for your video and it will appear in 
YouTube’s listings. However, you can set your video to either Unlisted or Private. 

Private - only you and up to 50 other users who you invite to view the video will be able to see 
your video. The video will not appear on your channel, in search results, or in playlists etc. To 
share a private video, your audience must have a YouTube account and you need to invite up to 
50 YouTube usernames to get access to your video.  

Unlisted: An unlisted video is a different type of private video. Unlisted means that only people 
who know the link to the video can view it. An unlisted video will not appear in any of 
YouTube's public spaces (such as search results, your channel, or the Browse page). You don't 
need a YouTube account to watch the video and there isn’t a 50 person sharing limit.  

If you don’t want your video to be Public, we would recommend using the ‘Unlisted ‘option. 
This means you can embed the video within your Moodle course. 

5. The default settings under the Advanced Settings tab are generally ok to leave as they are. 

6. However, you can change settings if you don’t want to allow comments or responses to the 
video etc.  

 

7. Save changes. 
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Step 5: Embed the YouTube video in your Moodle course 

If your video is Public, then you can search for it and add or embed it from within the course in the 
usual way. See our how-to document: Add or Embed YouTube video. 

If you have made your video Unlisted, then you can use the following method: 

1. Open your internet browser and go to http://www.youtube.com/. Log in to your account. 

2. On YouTube, locate the video content you would like to add to your Moodle area. 
Beneath the video, click the button Share. 

3. Click on the button Embed. The code will already be highlighted.  

4. Underneath the Embed code, you can change the settings of the video. You can usually leave the 
video size settings as default, although you may want to choose a smaller size for embedding in 
a label. 

5. You should probably un-tick the option ‘Show suggested videos when the video finishes’. 

6. As you change the settings, then the Embed code will change. 

7. When you have made all your changes, Copy (Ctrl + c) the code. Make sure you copy it all.  

 

http://moodle.glyndwr.ac.uk/pluginfile.php/25841/mod_resource/content/5/Add%20YouTube%20video.pdf
http://www.youtube.com/
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8. Now go to the Moodle course where you want to embed the video, and Turn editing on. 

9. Select the topic where you want the video to appear, and choose Add a resource… Label (or 
Page or Book). 

10. In the HTML/text editor, click on the HTML button. 

 

11. In the HTML Source Editor paste in (Ctrl + v) the Embed code and then click on Update. 

 

12. Save and return to course. 

13. The video will be embedded in the label (or page or book) and ready to play. 

 


